linearSolve
Block Category: Matrix Operation
Description: The linearSolve block solves systems of linear equations of the A * X = b, where A is an N-by-N matrix and X and b are N-by-1 matrices. This block will also compute the least squares solution to an over-determined system or the minimum norm solution to an under-determined system. 
The linearSolve block accepts as input an extended matrix (A | b). That is, if A is N-by-N and b is N-by-1, then the input matrix must be N-by- (N + 1) and the last column is of components of b. 

Example
The linearSolve block computes the values of three unknowns (x, y, and z) in the following three equations:
11x + 4y + 31x = -19
3x + 17y + 4z = 13
6x + 2y + 1z = 7
[image: linearSolve example 1]
lineDraw
Block Category: Animation
Inputs: The two sets of  x and y input connectors provide the x,y screen coordinate endpoints for the line. By varying these values, you can create movement.
The values fed into the input connectors represent display pixels. The x, y position 0,0 is the upper left corner of the window. Positive values extend to the right and down. For your line to appear on most video screens, keep its position within the bounds of a VGA screen (640x480). 
You must perform all coordinate conversion manually. 
Description: The lineDraw block lets you animate a line during simulation. You define the line by specifying two sets of x,y screen coordinate endpoints. You can also set the color, thickness, and style of the line.
[image: ]
Color: Lets you choose a line color from the color palette.
Style: Selects a style from the drop-down list.
Thickness: Specifies the thickness in the points. The thickness can be specified as an integer, decimal number, or variable. 
Example
See Examples > Blocks > Animation > lineDraw
ln

Block Category: Transcendental
Inputs: Real scalars, vectors, or matrices.
Description: The ln block generates the natural (Napierian) log of the input signal.
[image: ]
Label: Indicates a user-defined block|topic=Entering block labels label that appears when View > Block Labels is activated.
log10

Block Category: Transcendental
Inputs: Real scalars, vectors, or matrices.
Description: The log10 block generates the log base 10 of the input signal. The logarithm of 0 to any base is undefined. The logarithm of any number, when the base is the same number, is 1.
[image: ]
Label: Indicates a user-defined block|topic=Entering block labels label that appears when View > Block Labels is activated.
[bookmark: _Toc8017185]magPhase
Block Category: Arithmetic
Description: The magPhase block returns the magnitude and phase of the complex number. The magnitude is equal to

the phase is equal to the value

which is an angle expressed in radians. When y is positive and x is 0, the phase is equal to /2. When y is negative and x is 0, the phase is equal to 3/2.
[image: ]
Label: Indicates a user-defined block|topic=Entering block labels label that appears when View > Block Labels is activated.
map

Block Category: Nonlinear
Inputs: Floating- or fixed-point values. If you index in with fixed point, Embed automatically converts to fixed point with optimal scaling. You always enter the table data in floating point.
Description: The map block can be used for static function approximation with measured data, or it can be used for device calibration, such as thermocouple-voltage-to-temperature conversion.
The map block performs piecewise linear interpolated 1- 2‑, and 3-dimensional table look‑ups. You can set up a look-up table or change an existing one through the map block or by using the Lookup Table wizard|topic=Using the Lookup Table wizard. 
The types of data that can be used by the map blocks are:
Data files (DAT)
Comma separated text files (CSV)
Binary matrix, ASCII matrix, and general text data files (M, MAT, and TXT)
8-bit or 16-bit audio files (WAV) 
Excel spreadsheets (XLSX)

[image: ]
Extrapolate: Allows dependent variables to be linearly extrapolated for values beyond the bounds of the table using the last two data points in the table. This feature can be used for static function approximation with measured data or for device calibration, such as thermocouple-voltage-to-temperature conversion.
Interpolate: Allows dependent variables to be linearly interpolated for independent variable values between data points. This feature can be used for static function approximation with measured data or for device calibration, such as thermocouple-voltage-to-temperature conversion.
Map Dimensions
1-D Mapping: A one-dimensional map file has one independent variable, but can have from one to 16 dependent variable outputs. The first column is an independent variable range. The numbers in the independent variable column must be either increasing in order or decreasing in order, but not both. Each additional data column you supply in the map file yields an additional dependent variable. Use Edit > Add Connector|topic=Adding and removing connectors to add an output connector for each dependent variable column in the resulting map block.
The numbers to the right of 1-D Mapping refer to the dimensionality and range of the map vector. For example, 10x1[1:100] represents a 1D table with 10 elements ranging from 1 to 100.
Lines that are prefaced with a semi-colon (;) are treated as comments.
[image: ]
2-D Mapping: A two-dimensional map file has two independent variables and one dependent variable output. The first row contains the domain points for the first independent variable; and the first column (excluding the column member in row 1) represents the second independent variable. The position (1,1) must be left blank. 
Like one-dimensional mapping, the independent variable values must be either monotonically increasing or decreasing.
Lines that are prefaced with a semi-colon (;) are treated as comments.
The numbers to the right of 2-D Mapping refer to the dimensionality and range of the map vector. For example, 10x50[10:20, -10:10] represents a 2D table with 10 columns and 50 rows, where the minimum column is 10, the maximum column is 20, the minimum row is -10, and the maximum row is 10.
[image: ]
3-D Mapping: A three-dimensional map file has three independent variables and one dependent variable output. The format of the first seven lines is as follows:

1: Starts with #3D
2: Number of look-up values for dimension 1
3: Look-up values for dimension 1 (vector)
4: Number of look-up values for dimension 2
5: Look-up values for dimension 2 (vector)
6: Number of look-up values for dimension 3
7: Look-up values for dimension 3 (vector)
Lines 8 through n are elements of dimension 3 matrices of (dimension 1 columns) * (dimension 2 rows). Lines that are prefaced with double hyphens (‑‑), double slashes (//), or commas (,) are treated as comments.
Dependent variables are linearly interpolated for independent variable values between map points, and linearly extrapolated for values beyond the bounds of the table using the last two points in the table. This feature can be used for static function approximation with measured data or for device calibration, such as thermocouple-voltage-to-temperature conversion.
[image: ]
Map File Name: Specifies the name of the map file, or click Select File to select it. Map files can be DAT, CSV, M, MAT, TXT, WAV, or XLSX files. To open the specified file with the default text editor|topic=Setting the default text editor, click Browse Data.
Use First Row As Pin Labels: If the first row in the data file is text, you must activate the Use First Row As Pin Labels. When activated, the text is used as labels on the block connectors.
Examples
Examples of the map block are under Examples > Blocks > Nonlinear.
matrixConst
Block Category: Matrix Operation
Description: The matrixConst block displays the size of the matrix.
[image: ]
Columns: Indicates the number of columns in the matrix. 
Rows: Indicates the number of rows in the matrix. 
matrixIn
Block Category: Matrix Operation
Description: The matrixIn block outputs an N-by-M matrix. 
[image: ]
Columns: Indicates the number of columns in the matrix. 
Rows: Indicates the number of rows in the matrix. 
matrixMerge
Block Category: Matrix Operation
Description: The matrixMerge block merges two matrices into one. For a horizontal merge, the number of rows in each input matrix must be the same; for a vertical merge, the number of columns in each input matrix must be the same.
[image: ]
Horizontal: Represents the arguments horizontally.
Vertical: Represents the arguments vertically.

Example
Two identical matrices are input into two matrixMerge blocks, where the upper block merges the matrices vertically and the lower block merges them horizontally. 
[image: matrixMerge ex]
[image: matrixMerge ex 2]
matrixOut 
Block Category: Matrix Operation
Description: The matrixOut block accepts an N-by-M matrix. You can format the cells through the dialog. You can also adjust the size of the cells by moving their gridlines. 
[image: ]
Auto Resize Grid Columns: Automatically resizes the cell dimensions to fit the data.
matrixSize
Block Category: Matrix Operation
Description: The matrixSize block outputs the dimensions of a matrix.
max

Block Category: Nonlinear
Inputs: Scalar.
The max block compares scalar inputs for a higher value and generates an output signal with the higher value. 
[image: ]
Label: Indicates a user-defined block|topic=Entering block labels label that appears when View > Block Labels is activated.
[bookmark: _Toc107805389]maxElement
Block Category: Matrix Operation
Input: Vector or matrix.
Description: The maxElement block outputs the element (v) in the vector or matrix with the greatest value. The lower two outputs identify the row and column addresses of the element. 
[image: ]
Label: Indicates a user-defined block|topic=Entering block labels label that appears when View > Block Labels is activated.
meanSmooth

n = the number of elements in the window (the Averaging Window)
dT = the input data element at time T
Block Category: Matrix Operation
Description: The meanSmooth block calculates the mean average of the input signal within the given smoothing window. The output is the smoothed signal.
[image: ]
Averaging Window: Specifies the number of elements to be averaged. The meanSmooth block always uses the most recent elements.

Example
The meanSmooth block smooths a noisy input signal via a trailing mean with a user-defined window. The averaging window must be a positive integer. 
Near the start of the simulation the user-specified window is larger than the number of time steps (that is, the available data set); in this case, the window the block uses increases in size every time step until the number of time steps equals the user-specified window size.
[image: meanSmooth example]
medianSmooth
Block Category: Matrix Operation
Description: The medianSmooth block calculates the median of the input signal within the given smoothing window. The output is the smoothed signal.
[image: ]
Median Window: The number of elements from which the middle element is determined. The median window value must be an odd number that is greater than or equal to 3.

Example
The meanSmooth and medianSmooth blocks smooth a noisy input signal via a trailing mean or median with a user-defined window. The averaging window must be a positive integer (and additionally for the medianSmooth block, must be an odd number greater than three).
Near the start of the simulation the user-specified window is larger than the number of time steps (that is, the available data set); in this case, the window the block uses increases in size every time step until the number of time steps equals the user-specified window size.
Notice the meanSmooth and filter outputs are affected by the outliers, while the medianSmooth ignores them.
[image: medianSmooth example]
merge
Scalar:

Matrix:

Block Category: Nonlinear
Inputs: Real, complex, or fixed-point scalars, or vectors, matrices, or alphanumeric strings. If x1 is a matrix, x2 and x3 should have the same dimension.
Description: The merge block expects a Boolean signal on x1. If the signal on x1 is floating point, it is automatically truncated to integer. The block output is the value presented on x2 if x1 is nonzero; otherwise, the output is x3. The letters b, t, and f on the input connectors indicate Boolean, True, and False.
The merge block is particularly well-suited for performing if-then-else decisions. 
[image: ]
Label: Indicates a user-defined block|topic=Entering block labels label that appears when View > Block Labels is activated.

Examples
1. Simple If-Then-Else using merge block
[image: merge blk example 1]
2. Cascading If-Then-Else using merges
[image: merge blk example 2]
mesh3D
Block Category: Animation
Inputs: 4 x 4 transformation matrix and an integer that represents the animation number, which corresponds to the animation that is to be executed.
Description: The mesh3D block lets you plot mesh data from a DirectX file (X). 
The mesh3D block is a DirectX block; it recognizes the following coordinate system:
[image: DirectX%20coordinate%20system]

[image: ]
Mesh File: Indicates the name of the DirectX X file to be used as input to the mesh3D block. If you do not know the name, click … to find it.
Mesh Properties: Indicates the center of the bounding sphere, radius, and number of animation sets.
meter

Block Category: Signal Consumer
Description: The meter block displays signals in a gauge- or bar-style meter. Initially, the meter block appears as a gauge-style display with one input connector. 
You can display up to eight signals in a meter block. To change the number of input connectors, use the [image: ] [image: ] toolbar buttons, or Edit > Add Connector or Edit > Remove Connector|topic=Adding and removing connectors. When you have multiple input signals, each signal is displayed in a separate meter window. 
[bookmark: _Hlk116050719]You can change the size or shape of the meter block for better viewing by dragging the its edges or corners.
Gauge meter
[image: ] 
Style: Switches between bar and gauge display.
Submeter 
Color Zones: The rim of the gauge can be divided into up to five zones. For each zone, you can define the range of the zone and the color of the zone.
Dial Color: Indicates the color of the dial. You can control the transparency and gloss reflection.
Dial Transparency/Glossy Reflection: Controls the transparency and reflection of the dial color. 
Fancy Pointer: Uses a 3D pointer.
Foreground Color: Specifies the color of the tick marks, submeter title, and start/end values.
Major/Minor Divisions: Indicates the number of major tick marks on the gauge and the number of minor tick marks between major ticks.
Start/Stop Angle: Indicates the position on the gauge where the start and stop values appear. Values are specified in degrees and are calculated in a clockwise direction. 0 degrees is at 3 o’clock on the gauge.
Start/Stop Value: Indicates the lower and upper limit of the range of values.
Submeter #: Indicates the meter whose characteristics are to be edited.
Title: Indicates a title for the specified meter. The title appears below the center of the gauge.
Text Labels: When activated, overwrites the Start and Stop values with the text specified in the Start and End boxes.
Window Title: Indicates a title for the meter block. The default is Meter.
Bar meter
[image: ]
Appearance: Opens the Appearance dialog. Click Foreground to color the axis label and scale text; click Background to color the plotting area. The color you specify overrides the color specified with View > Colors. 

You can alternatively specify a bitmap image background for the plotting area. Type the file name directly into the Bitmap box or select one using Select Bitmap. The specified bitmap image file overrides any background color selection.
Axis Ticks: Displays grid ticks established by Fixed Divisions.
Horizontal Bar: Displays the bar meter horizontally.
Meter #: Indicates the individual meter whose characteristics are to be examined or edited. Meter 1 corresponds to the signal entering the top input connector, Meter 2 corresponds to the signal entering the second from the top input connector, and so on.
Settings for Meter
Axis Label: Indicates a name for the axis on which the signal is displayed. In a gauge display, the axis label is displayed horizontally across the top of the display; in a bar display, the axis label is displayed vertically along the left side of the display.
Fixed Divisions: Indicates the number of grid ticks.
Upper and Lower Bound: Controls the upper and lower bounds of the meter display. The defaults are 1 and 0, respectively.
Style: Switches between bar and gauge display.
Window Title: Indicates a title for the meter block. The default is Meter.
min

Block Category: Nonlinear
Inputs: Scalar
Description: The min block compares two scalar inputs for a lower value and generates an output signal with the lower value. 
[image: ]
Label: Indicates a user-defined block|topic=Entering block labels label that appears when View > Block Labels is activated.
[bookmark: _Toc101781434][bookmark: _Toc101858147][bookmark: _Toc101858184][bookmark: _Toc106612472][bookmark: _Toc107805390]minElement
Block Category: Matrix Operation
Description: The minElement block accepts one matrix input and produces three outputs. The top output is minimum value of the element, and the lower two outputs are the row and column addresses of the element.
[image: ]
Label: Indicates a user-defined block|topic=Entering block labels label that appears when View > Block Labels is activated.
[bookmark: _Toc390242353][bookmark: _Toc390242385][bookmark: _Toc390752391][bookmark: _Ref449421317][bookmark: _Ref449422003]mldivide

Block Category: Matrix Operation
Description: The mldivide block outputs the matrix left division of a and b. It uses LAPACK’s dgesv routine to compute the solution to a real system of linear equations A * X = B. For more information, see https://software.intel.com/sites/products/documentation/doclib/mkl_sa/11/mkl_lapack_examples/dgesv.htm.
multiply
Block Category: Matrix Operation
Inputs: Vector.
Output: Vector.
Description: The multiply block performs a matrix multiplication. 
To multiply two or more scalars, use the *|topic=* block. To perform a single value summation of an element-by-element multiply of two vectors, use the dotproduct block.	Comment by ComponentOne Doc-To-Help: dotProduct
[image: ]
Label: Indicates a user-defined block|topic=Entering block labels label that appears when View > Block Labels is activated.
not

Block Category: Boolean
Inputs: Real, complex, or fixed-point scalars, or vectors or matrices.
Description: The not block generates the Boolean NOT of the input signal. The output is TRUE when the input is FALSE; and the output is FALSE when the input is TRUE.
If you right-click the not block, the Boolean block menu appears allowing you to assign a different function to the block.
[bookmark: _Ref8030301]OLEobject
Block Category: Extensions > IoT
Description: The OLEobject block lets you embed existing objects from files or insert new blank objects|topic=Embedding objects with OLE and create the information right in your diagram. 
or

Block Category: Boolean
Inputs: Real, complex, or fixed-point scalars, or vectors or matrices.
Description: The or block generates the bitwise OR of 2 – 256 scalar input signals. The output of the or block is TRUE when at least one of the inputs is TRUE. When all the inputs are FALSE, the output is FALSE.
If you right-click the or block, the Boolean block menu appears allowing you to assign a different function to the block.
parabola

Block Category: Signal Producer
The parabola block generates a parabolic signal.
[image: ]
Label: Indicates a user-defined block|topic=Entering block labels label that appears when View > Block Labels is activated.
Slope Rate: Scales the curvature of the parabola. The default is 1. You can enter a value in hexadecimal notation|document=WordDocuments\Chap 4 Working with Blocks.docx;bookmark=hexadecimal_notation or as a C expression|topic=Entering C expressions.
Time Delay: Indicates an offset that is used in the calculation of a signal. For a constant-valued delay, wire the block into a unitDelay or timeDelay block with an initial condition of the desired constant value. The default is 0 sec. You can also enter in hexadecimal notation|document=WordDocuments\Chap 4 Working with Blocks.docx;bookmark=hexadecimal_notation or a value as a C expression|topic=Entering C expressions.
parameterUnknown
Block Category: Optimization
Description: The parameterUnknown block works with the cost block to find globally optimal values that minimize a scalar cost function|topic=Performing Global Optimization. 
[bookmark: _Toc182032128][bookmark: _Ref404407273]pareto
Block Category: Random Generator
Description: The pareto block generates random numbers for a standard Pareto distribution. Pareto originally used this distribution to describe the allocation of wealth among individuals since it show rather well the way that a larger portion of the wealth of any society is owned by a smaller percentage of the people in that society. For more information, see http://en.wikipedia.org/wiki/Pareto_distribution.
[image: ]
Alpha: Specifies the mode of the curve. You can enter a value in hexadecimal notation|document=WordDocuments\Chap 4 Working with Blocks.docx;bookmark=hexadecimal_notation or as a C expression|topic=Entering C expressions. 
Beta: Controls the shape of the curve. You can enter a value in hexadecimal notation|document=WordDocuments\Chap 4 Working with Blocks.docx;bookmark=hexadecimal_notation or as a C expression|topic=Entering C expressions.   
Label: Indicates a user-defined block|topic=Entering block labels label that appears when View > Block Labels is activated.
plot

Block Category: Signal Consumer
Description: The plot block displays data in a customizable two-dimensional plot. You can customize the plot and control how data is displayed. 
Use Edit > Clear Plots/Display|topic=Clearing displays and plots to clear the plot.
Memory usage: The plot block uses eight bytes per data point of RAM. If you are running a long simulation at a small step size, it is possible to exceed your RAM limit. For example, a simulation with a step size of 0.005 and duration of 32236 would require 6.4 million points of data per plot trace. At eight bytes per point, each plot trace uses 51MB of RAM. If you used all eight traces on a plot block, you would exceed 412MB of RAM.
Memory usage is calculated at the start of a simulation so you will know immediately if the simulation cannot run due to memory issues.
Basic time domain plots: When you wire a plot block into your diagram and run a simulation, the simulation data is initially presented in time domain. All the signals are plotted on the y-axis; the x-axis represents time. As data points arrive to be plotted, plot bounds are dynamically re-scaled and data points are automatically connected with line segments.
Code generation for plots: If you have a version of Embed that lets you generate code, plot blocks are ignored during code generation.
[image: ]
In the above plot, ball position and air friction are displayed as functions of time. The peak ball position follows an exponential decay, governed by air viscosity. The signals are distinguished by line patterns, a feature the plot block automatically performs when displaying or printing on monochrome devices. To make the plot more meaningful, signal labels and a title were also added.
[bookmark: _Ref404194682]XY plots: In an XY plot, you use one input signal to represent X coordinate generation. As time advances, the remaining input signals are plotted relative to the x-axis signal. To create XY plots, use the XY Plot and X-Axis|topic=Plot Options tab parameters in the Options dialog.
[image: ]
In the XY plot above, ball position is plotted against air friction. At time 0, the ball position is at 2 and air friction is at 0. Over the course of the simulation, the ball position moves counterclockwise, following a three-sided decaying cycle.
[bookmark: ZoomingandSizingPlots]Zooming and sizing plots: 
To resize plots
You can change the size or shape of the plot block by clicking on the Maximize button in the upper right-hand corner of the plot or dragging its edges or corners.
To zoom in
You can zoom in on plots to view the data at a magnified size. You can zoom in several times in a row for greater magnification. If the area you are zooming in on does not contain at least one data point, the magnified area will be blank.
1. Point to one corner of the area you want to select.
To anchor the corner, CTRL+depress.
Drag the pointer until the box encloses the area you want to magnify. A status box in the lower left corner of the plot displays the pointer position. 
Release the button and CTRL key.
To zoom out
CTRL+right-click the plot.
Printing plots: To print just a plot, click the control-menu box in the upper left corner of the plot and select Print. 
[bookmark: _Ref182729862]Plotting vector data: To plot vector data, use the External Trigger|topic=Plot Options tab parameter in the Options dialog. This gives you control over when to update vector data. 
To save vector data to a file and read it in another application, such as Excel, use the export|topic=export block.
Plot Options tab
[image: ]
Actual Point Count: Displays the number of data points plotted.
Clear Overplot Y: Clears all signal traces from a plot.
Decibel Y: Rescales the y-axis to display the values in decibels.
dT: When you activate External Trigger, the plot block acquires data at an unknown rate. dT allows you to specify the delta time between data points.
External Trigger: Determines whether simulation data is displayed in the plot based on the value of an external trigger. When activated, a round input connector is attached to the plot block. When signal values entering the external trigger are 1, simulation data is plotted; when signal values entering the external trigger are 0, simulation data is not plotted. This parameter is particularly useful when plotting vector data. See Plotting vector data. To save vector data to a file and read it in another application, use the export|topic=export block.
Fixed Bounds: Specifies the region of the plot you want to view. Note that the plot will always plot from the Start to the End values in the System Properties dialog|topic=Setting up the simulation range. When you activate XY Plot, the Y Upper Bound and Y Lower Bound values under the Axes|topic=Plot Axes tab tab are used.
Frequency Domain: Obtains the frequency power spectrum using the Fast Fourier Transform (FFT) algorithm. 
Do not obtain frequency power spectrum data until after you have run a simulation. If you halt the simulation prematurely, the fidelity of the FFT is diminished. 
If your frequency domain plot produces unexpected peaks, check the simulation step size to verify that your sampling rate is adequate for obtaining accurate results. Then, based on the simulation step size and range, check Plotted Points to verify that you are indeed plotting each time step.
Geometric Markers: Overlays signal traces with geometric markers.
Grid Lines: Extends grid lines from the vertical and horizontal axis coordinates. The vertical and horizontal spacing of grid lines is controlled by the spacing of the axis coordinates. Embed automatically establishes reasonable axis coordinate spacing and hence controls the grid frequency.
Line Type: Point displays signal values as individual data points. Point plots show the separation of data as time advances. 
Line connects data points with solid line segments. On color displays, line segments are the color of the corresponding input connector. On monochrome displays and printers, line patterns distinguish signal traces. You may have to lower the point count to allow enough room between data points for the pattern to be displayed. If this is not satisfactory, you can overlay signal traces with geometric markers.
Discrete holds the Y value constant from point to point. A discrete plot is helpful when data points are irregularly spaced and you do not know where the curve is accurate.
Log X and Log Y: Allow data to be plotted in logarithmic and semi-logarithmic coordinate systems. When you specify a logarithmic or semi-logarithmic plot, you cannot plot negative values on the log axis. Any negative value will be clipped to the low end of the scale. When neither parameter is activated, the plot defaults to linear.
Marker Count: Determines the number of markers overlaid on each signal trace. By default, Embed overlays each data point in a signal trace with a marker; however, if this is not satisfactory, you can enter a new number in Marker Count. Entering -1 in this box indicates all data points have markers associated with them.
Max Plotted Points: Determines the smoothness and accuracy of a plot. The more data points you plot, the smoother and more accurate the plot. However, increasing the number of plotted data points also increases the time it takes to print and display the plot.
The maximum number of data points that can be plotted is 250 million. Entering 0 plots every data point.
If you know the maximum number of data points you want plotted in all your plots, you can set it as the default|topic=Setting simulation defaults.
Multiple XY Traces: Creates two independent XY plots, which allows two signals to be superimposed. The XY Plot parameter must be activated to use Multiple XY Traces.
Over Plot: Displays the results of multiple simulation runs in a single plot. This allows for better insight into how small changes can affect overall system performance. Enter the number of overplots in Plot Count.
Past Weight Value: Specifies the values of the previous simulation runs to be averaged into the current run. Specify the value as a fraction of 1.
Plot Averaging: In multi-run simulations, the values of the previous run are averaged into the current run using Past Value Weight as a fraction of 1. This is useful for filtering out noise.
It is recommended you activate Fixed Bounds. In addition, you must activate Auto-Restart under System > System Properties > Range|topic=Setting up the simulation range.
Plot Count: Sets the number of overlapping plots.
[bookmark: ReadCoordinatesPlotOptionsProperties]Read Coordinates: Overlays the plot with a set of crosshairs and displays crosshair position at the bottom of the plot. When you click the mouse button, Embed freezes the crosshairs. Click again to erase the crosshairs.
Retain Coordinates: Displays two crosshairs. One crosshair is frozen at the last known x,y position. The other is controlled by the position of the pointer.
Save Data To File: Opens the Select File dialog to specify a file to which the plot data is to be saved. 
Snap To Data: Causes the data point closest to the pointer to have a magnetic-like pull on the crosshair. As you move the pointer, the crosshair continues to jump to the closest data point.
Truncate FFT Data to 2^n: Truncates data down to the nearest power of 2. If you do not activate this parameter, the data buffer is padded with zeros to round up to the nearest power of 2. This parameter can be turned on only when Frequency Domain is activated.
XY Plot and X Axis: Together, XY Plot and X Axis let you use one input signal to represent X coordinate generation. As time advances, the remaining input signals are plotted relative to the x-axis signal.
To specify an XY plot
1. Activate XY Plot.
In the X Axis drop-down menu, choose the input signal to be used for x coordinate generation: 1 represents the input signal attached to the top connector on the plot block, 2 represents the input signal attached to the second to the top connector on the plot block, and so on.
Click OK, or press ENTER.

Plot Labels tab
[image: ]
Title and Subtitle: Provide names for your plots. Titles and subtitles can be up to 80 alphanumeric characters. The title appears in the plot title bar; the subtitle is displayed in the top area of the plot. By default, plots are titled Plot and have no subtitles.
Trace 1, Trace 2, …: Specifies labels for up to eight input signals. Trace 1 corresponds to the top input connector, Trace 2 corresponds to the next lower connector, and so on. Signal labels can contain up to 80 alphanumeric characters.
[bookmark: YLabelPlotLabelsProperties]X Label and Y Label: X Label specifies a label for the x-axis. Y Label specifies a label for the y-axis. Axis labels can contain up to 80 alphanumeric characters.
To label the x-axis on an XY plot, Embed automatically labels the x-axis with the label for the input signal used for x coordinate generation. For example, if you activate XY Plot and choose 2 under X Axis, Embed uses the label assigned to input signal 2.
For plots with multiple subplots, you can create y-axis labels for each subplot by separating them with a semi-colon (;). Insert a blank space for unlabeled subplots.

Plot Axes tab
[image: ]
2 Axes: Enables right side plot axis. You can then select Axis 1 or Axis 2. The 2 Axes checkbox is available only if Sub Plot Count is set to 1.
Axis Divisions
Fixed Tick Count, X Division, Y Division: You can override the plot’s grid tick division by activating Fixed Tick Count and entering values to X Divisions and Y Divisions. The numbers you enter indicate the number of grid ticks on each axis.
Retrace Options
Allows you to configure a plot as an eye diagram. 
Retrace Enabled: Activate Retrace Enabled and specify the desired interval in Interval. In Start Time and End Time, enter the start and end times for the eye diagram. Eye diagrams are particularly useful for analyzing digital data waveforms.
[bookmark: SubplotCountParameter]Subplot Count: Specifies up to eight subplot windows, allowing you to plot each signal trace in a separate window. This feature is useful when signal traces overlap in range and obscure each other. You can apply a label to each subplot.
Time Scaling: Specifies x-axis scaling in microseconds, milliseconds, seconds, minutes, hours, and days. When you select a different time axis scale, Embed re-calculates the values in X Upper Bound and X Lower Bound. When you close the dialog, the x-axis is scaled to the time you chose.
Uniform Subplot Scales: Controls whether subplots are uniformly scaled. This parameter is available when you have two or more subplots.
Y Upper Bound, Y Lower Bound, X Upper Bound, and X Lower Bound: Specify the upper and lower bounds for the x and y axes. These bounds are in effect when you activate Fixed Bounds under the Options|topic=Plot Options tab tab.
Plot Appearance tab
[image: ]
Bitmap: Specifies a bitmap image to be used as background in the plotting area. If you do not know the name of the file, click Image to find it. The specified bitmap overrides any background color selection.
Color
Background: Specifies the plotting area color. 
Foreground: Specifies the axis labels and scaling text color.
Override Default Colors: Overrides the color specified in View > Colors|topic=Changing screen element colors.
Plot Traces tab
[image: ]
Trace, Color, Marker: Selects the color and marker for each signal.
plot3D
Block Category: Signal Consumer
Description: The plot3D block provides an easy method to plot and visualize vector and matrix data as three-dimensional objects. You can manipulate the 3D objects in the following ways:
Display the objects as data points, curves, or solid surfaces 
Use a light source to create realistic surfaces
Export the data and mesh dimensions of the objects to standard file formats.
Rotate, zoom, and drag the 3D objects
Control the axes, grid lines, and bounding box for the plot
Memory usage: There is finite memory for plot3D plots. If the plot3D block’s memory usage, which is calculated at the start of the simulation, exceeds the memory available, Embed displays an Out of Memory message and aborts the simulation.
Resizing plots: You can change the size or shape of the plot3D block for better viewing by clicking on the Maximize button in the upper right-hand corner of the plot3D or dragging its edges or corners.

Rotating, dragging, and zooming a 3D object: Using the following keyboard and mouse key combinations, you can manipulate the plot in the following ways:
	To 
	Do this 

	Rotate the plot 
	CTRL+drag-left-mouse-button over the plot

	Drag the plot to a different location within the 3D plot window
	CTRL+drag-right-mouse-button over the plot

	Zoom in and zoom out
	Roll the mouse wheel or CTRL+SHIFT+ drag-right-mouse-button over the plot


Note: When you activate the Enable Diffuse Lighting and Setup Light parameters under the Lighting tab, the above keyboard and mouse key combinations are used to control light position and direction. 
3D Plot Options tab
[image: ]
External Trigger: You can set an external trigger to determine if data is displayed in the plot based on the value of the trigger. When activated, External Trigger places a round input connector on the 3Dplot block. When signal values entering the external trigger are 1, data is plotted; when signal values entering the external trigger are 0, data is not plotted.
Inputs
Datapoint: Data points in 3D space that can draw a trajectory or a parametric surface. A parametric surface accepts a 3 x 1 vector on each simulation. It is defined as follows:
x = x(u,v)
y = y(u,v)
z = z(u,v)
[image: ]
[image: ]
Matrix: An n x m array of data that defines the surface of the plotting object.
x, y = matrix dimensions
z = value of Axy
Surface Matrix: Accepts the following:
3 x (first-mesh-dimension * second-mesh-dimension)
The matrix provides the entire mesh at once.
Vector: A 1 x n array of data that defines the surface of the plotting object. You can only specify this type of input for a waterfall plot.
Reset Matrix: Undoes the position and rotation applied to the 3D object and resets the object to correspond to its initial transformation matrix. When resetting the transformation matrix, Embed brings the 3D axes (and eventually the 3D object) back into their initial position. The x-axis is parallel to the plane of the screen and points from left to right; the z-axis is parallel to the plane of the screen and its positive direction is bottom to top; and the y-axis is perpendicular to the screen pointing from the viewer.
Save Data to File: Saves the data points to a DAT file. Each x, y, and z coordinate is saved to a single, comma-separated line in the file. A header is included at the top of the file that identifies when it was created and the diagram from which it was created. The DAT file can be used as input to any block that recognizes DAT files, such as the import block.
Save Mesh to File: Saves the mesh as a DirectX file (X) and can be used with any application that accepts X files.
Style
Buffer Size: Indicates the actual number and maximum number of data points to be plotted. If the value entered in Max is 0, the value entered in Actual is used to plot the object. Actual is a read-only parameter; it cannot be changed.
Curve: Plots a 3D curve or line. The following is 3D curve plot of the Lorenz attractor:
[image: 3D%20curve%20-%20Lorenz%20Attractor]
Max Plotted Samples: Indicates the number of data vectors to be plotted simultaneously. This parameter is available only when you have selected a waterfall plot style.
Mesh Dimensions: Specifies the mesh dimensions. The mesh dimensions should be close to the number of nodes used to produce the 3D object; otherwise, the 3D object may appear distorted when plotted.
Surface: Generates a surface 3D plot. Input for a surface plot can be matrix, datapoints, or surface matrix. 
You can control specific characteristics of the surface plot under the Axes, Lighting, and Appearance tabs.
Waterfall: Plots multiple snapshots of 1 x n vector data. In a waterfall plot, all the snapshots of data are displayed in a single image where each snapshot is offset from the previous snapshot. Input must be a 1 x n vector.
You can control specific characteristics of waterfall plot under the Axes, Lighting, and Appearance tabs.
Title: Provides a name for the 3D plot. Titles can be up to 80 alphanumeric characters. The title appears in the 3D plot title bar. By default, 3D plots are titled Plot3D.
3D Plot Axes tab
[image: ]
Axes Style
Corner: Indicates that the axes extend from a single corner. The axes remain fixed, even as you rotate the 3D object.
None: Indicates that no axes are displayed.
Perimeter: Indicates that the axes extend from the perimeter of the plot. The axis lines move as you rotate the 3D object. Additionally, the axes remain in front of the 3D object.
Color: Specifies colors for the x-, y-, and z-axes. To specify the color for an axis and its label, click … . The color you choose is previewed next to Color.
Fixed Bounds: When you activate Fixed Bounds, you can specify the region of the plot that you want to view by selecting the plotting bounds. The plotting bounds are obtained from the values specified in X-Axis, Y-Axis, and Z-Axis Upper and Lower Bound. 
The 3D plot coordinate system is shown below:
[image: VisSim%203d%20coordinate%20system]
Grid Lines: Extends grid lines from the three axes. Grid frequency – that is, the x, y, and z spacing of grid lines – is controlled by the spacing of the axis coordinates. Embed automatically establishes reasonable axis coordinate spacing and hence controls the grid frequency. 
To change the color of the bounding box, click the corresponding …. After you select a color, it is displayed to the left of the … button.
Label: Specifies labels to the x, y, and z axes. Axis labels can contain up to 80 alphanumeric characters.
Show Box: Establishes a bounding box around the 3D object. To change the color of the bounding box, click the corresponding … button. After you select a color, it is displayed to the left of the … button.
X-Axis, Y-Axis, and Z-Axis Upper and Lower Bounds: Determines the upper and lower plotting bounds for the x, y, and z axes. You can specify the bounds only when Fixed Bounds is activated.
3D Plot Lighting tab
[image: ]
Enable Diffuse Lighting: Lets you create and adjust the direction of the light. This parameter must be activated to apply light source settings.
Note that when creating a 3D surface plot, if you do not activate Enable Diffuse Lighting and select a solid color under the Appearances tab, the 3D object will appear flat.
Inverse Face Normal Orientation: Inverts the direction that the light bounces off the surface of the 3D object. Note that Enable Diffuse Lighting must be activated to activate Inverse Face Normal Orientation.
Light Color: Specifies the color of the point, spot, or directional light. 
To specify light color for point, spot, and directional light
1. Activate Enable Diffuse Lighting.
Click Light Color.
In the Color dialog, choose a color for the light.
Click OK.
Light Direction: Allows you to specify the direction of the light for Spot light source types. See the Light Source Type for directions on how to specify light direction.
Light Position: Allows you to specify the position of the light for Spot and Point light source types. See the Light Source Type for directions on how to specify light position.
Light Source Type
Directional: Directional light has color and direction that you can control, but not position. The light it generates is referred to as parallel light; that is, all directional light travels through an object in the same direction. 
To specify directional light direction using the mouse 

1. Activate Enable Diffuse Lighting.

2. Activate Setup Light. 

3. Under Light Source Type, activate Spot.

4. Click OK.

In the plot window, a light directional symbol [image: directional%20symbol]appears. This symbol represents the light direction. In the upper left corner of the plot window, the x, y, and z coordinates of the direction of the light source are displayed.

5. To control position of the light directional symbol, hold down CTRL+drag-the-mouse.

As you drag the mouse the light directional symbol moves accordingly and sheds light on the 3D object appropriately.

Point: Point light has color and position that you can control; however, it has no single direction. That is, it gives off light equally in all directions.
To specify point light position and range through the dialog 

1. Activate Enable Diffuse Light. 

2. Under Light Source Type, activate either Point or Spot.

3. Enter the Light Position coordinates under X, Y, and Z.

4. Under Range, enter a value that indicates how far the light travels.

5. Click OK.

The plot window will reflect the light position you have specified and light the object accordingly.

Spot: Spot light has color, position, and direction that you can control. The light emitted from a spot light has a narrowly focused inner cone of light as well as an outer cone of light. The light intensity diminishes as it reaches the outer cone, and there is no light beyond the outer cone. To control the size of the inner and outer cones, the elements Phi and Theta are used. The following illustration shows the relationship between these elements:
[image: spotlight]

To specify spot light position, direction, range Phi, and Theta through the dialog 
You can only enter the range, Phi, and Theta values through the dialog.

1. Activate Enable Diffuse Light. 

2. Under Light Source Type, activate Spot.

3. Enter the Light Direction coordinates in the corresponding X, Y, and Z text boxes.

4. Enter the range, Phi, and Theta values in the corresponding text boxes.

5. Click OK.

The plot window will reflect the light position you have specified and light the object accordingly.

To specify spot light position and direction using the mouse 
1. Activate Enable Diffuse Lighting. 

2. Activate Setup Light.

3. Under Light Source Type, activate Point.

4. Click OK.
In the plot window, a positional/directional symbol [image: Positional%20directional%20symbol]appears, which represents the light source. In the upper left corner of the plot window, the X, Y, and Z coordinates of the position and direction of the light source are displayed. 

5. To control the position of the light source, CTRL+right-click and drag to move the [image: Positional%20directional%20symbol]symbol and shed light on the 3D object appropriately.

6. To control the direction of the light source, CTRL+click and drag to move the arrow attached to the [image: Positional%20directional%20symbol] symbol and shed light on the 3D object appropriately.
Phi: Specifies the inner cone of a Spot light source. See Light Source Type for Phi specifications.
Range: Allows you to specify the range of the light for a Spot light source. See Light Source Type for light range specification directions.
Setup Light: Lets you control the position and direction of the light using the mouse. For more information, see Light Source Type.
Theta: Allows you to specify the outer cone of a Spot light source. See Light Source Type for Theta specification directions. 
3D Plot Appearance tab for surface plots
If you select a surface plot, you use the Appearance property sheet to control the surface style and color, the background color of the plot, and the edge color.
[image: ]
Background Color: Specifies the background color of the plotting window. To choose a new color, click … and make the appropriate selections in the Color dialog. Click OK when you are satisfied with your selection.
Color
Map: Applies a spectrum of color. To choose the saturation and lamination of the colors, click More and make the appropriate selections in the Mapping Color Setup dialog. Click OK when you are satisfied with your selection.
Solid: Applies a solid color. To choose a new color, click … and make the appropriate selections in the Color dialog. Click OK when you are satisfied with your selection.
The following are examples of different surfaces depending on the Enable Diffuse Light and Surface Color settings:
[image: Surface%20plot%20with%20diffused%20light]
Enable Diffuse Light is activated. Surface Color is set to solid yellow.
[image: Surface%20plot%20without%20diffused%20light]
Enable Diffuse Light is de-activated. Surface Color is set to solid yellow.
[image: Surface%20plot%20with%20diffused%20light%20and%20Map]
Enable Diffuse Light is activated. Surface Color is set to Map.
[image: Surface%20plot%20without%20diffused%20light%20and%20with%20map]
Enable Diffuse Light is de-activated. Surface Color is set to Map.
Edge Color: If you selected a Surface with Edges plot style, you specify the color of the edges (that is, the mesh superimposed over the plot) with Edge Color. When you click … to the right of the Edge Color box, the Color dialog appears that allows you to choose a color, its hue, saturation, and lamination, as well as create a custom color. When you are satisfied with the color, click OK to return to the Appearance tab. 
The following are examples of different surfaces depending on the Enable Diffuse Light and Surface Color settings:
[image: Surface%20with%20edges%20plot%20with%20diffuse%20light%20and%20with%20solid%20color]
Enable Diffuse Light is activated. Surface Color is set to solid yellow. 
[image: Surface%20with%20edges%20plot%20without%20diffuse%20light%20and%20with%20solid%20color]
Enable Diffuse Light is de-activated. Surface Color is set to solid yellow.
[image: Surface%20with%20edges%20plot%20with%20diffuse%20light%20and%20with%20map]
Enable Diffuse Light is activated. Surface Color is set to Map.
[image: Surface%20with%20edges%20plot%20without%20diffuse%20light%20and%20with%20map]
Enable Diffuse Light is de-activated. Surface Color is set to Map.
Surface Style
Dots: Generates dots in place of surface vertices. The following is a data point 3D plot of half a Klein bottle:

[image: Datapoint%20plot]
Like with the surface, surface with edges, and wireframe plots, you can change the light and color characteristics to change the appearance of the plot.
Solid: Generates a solid surface 3D plot.
Solid with Edges: Generates a solid surface 3D plot with a mesh wiring superimposed over it. You specify the mesh dimensions in the Mesh parameters under the Options tab. You can also save the mesh to file with Save Mesh to File, also contained in the Options tab.
To set the color of the mesh, use Edge Color.
Input to a surface with edges plot can be matrix, data points, or surface matrix. The following are solid surface with edges 3D plots, the first has matrix input, the second has data points, and the third has surface matrix:
[image: surface%20with%20edges%20and%20surface%20matrix%20on%20local%20bounds%20diagram]
[image: Surface%20plot%20with%20edges]
[image: surface%20with%20edges%20and%20surface%20matrix%20on%20heartball%20diagram]
Wireframes: Generates a wireframe surface. Input can be matrix, data points, or surface matrix. The following is a wireframe 3D plot of half a Klein bottle:
[image: Wireframe%20plot]
3D Plot Appearance tab for curve plots
If you select a curve plot, you use the Appearance property sheet to control the curve style and line thickness, input connector color, and background color of the plot.
[image: ]
Background Color: Specifies the background color of the plotting window. To choose a new color, click … and make the appropriate selections in the Color dialog. Click OK when you are satisfied with your selection.
Color: Applies a color to the specified input connector and corresponding curve. To choose a new color, click … and make the appropriate selections in the Color dialog. Click OK when you are satisfied with your selection. 
Curve Style
Dots: Plots the individual data points, as shown in the Lorenz Attractor plot below:
[image: 3D%20dot%20-%20Lorenz%20Attractor]
Line: Plots a 3D curve or line, as shown in the Lorenz Attractor plot below:

[image: 3D%20curve%20-%20Lorenz%20Attractor]
Input Pin: Lets you specify up to eight input connectors. Each connector represents an individual curve. To add or remove or remove connectors, use Add Connector and Remove Connector|topic=Adding and removing connectors.
Thick Line: Turns on antialiasing mode, which results in thicker, smoother, and uninterrupted lines.
3D Plot Appearance tab for waterfall plots
If you select a waterfall plot, you use the Appearance property sheet to control the waterfall style and color.
[image: ]
Background Color: Specifies the background color of the plotting window. To choose a new color, click … and make the appropriate selections in the Color dialog. Click OK when you are satisfied with your selection. 
Color
Map: Applies a spectrum of color. To choose the saturation and lamination of the colors, click More and make the appropriate selections in the Mapping Color Setup dialog. Click OK when you are satisfied with your selection.
Solid: Applies a solid color. To choose a new color, click … and make the appropriate selections in the Color dialog. Click OK when you are satisfied with your selection. 
The following are examples of different surfaces depending on the Enable Diffuse Light and Surface Color settings:
[image: waterfall%20solid%20enable%20diffuse%20lighting]
Enable Diffuse Light is activated. Surface Color is set to magenta.
[image: waterall%20solid%20disable%20diffuse%20lighting]
Enable Diffuse Light is de-activated. Surface Color is set to magenta.
[image: waterfall%20map%20enable%20diffuse%20lighting]
Enable Diffuse Light is activated. Surface Color is set to Map.
[image: waterfall%20map%20disable%20diffuse%20lighting]
Enable Diffuse Light is de-activated. Surface Color is set to Map.
Waterfall Style
Curves: Specifies that each segment of a waterfall surface be represented as a continuous line.
[image: Waterfall%20plot%20with%20curves]
Dots: Specifies that the waterfall surface be represented as individual data points:
[image: Waterfall%20plot%20with%20dots]
Planes: Specifies that each segment of a waterfall surface be represented as a 2D plane.
[image: Waterfall%20with%20planes]
Surface: Specifies that the waterfall surface be represented as a solid surface.
[image: Waterfall%20plot%20with%20solid]
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